サブネット計算機(CIDR)

CIDR から IPv4 のネットワーク、ブロードキャスト、ホスト範囲、マスクを計算します。

このツールについて

10.0.0.0/24 のようなプレフィックス付き、またはネットマスク付きの IPv4 アドレスを入力すると、ネットワークアドレス、ブロードキャストアドレス、使用可能なホスト範囲、ホスト数、ワイルドカードマスク、2 進数表示が得られます。別のアドレスがサブネットに属しているかも確認できます。

使い方

  1. 192.168.1.10/24 のようなプレフィックス付き、またはネットマスク付きの IPv4 アドレスを入力します。
  2. ネットワーク、ブロードキャスト、ホスト範囲、ネットマスク、ワイルドカード、使用可能なホスト数を確認します。
  3. 別のアドレスがサブネット内にあるか確認します。
  4. 任意で、より長いプレフィックスを使ってネットワークを小さなサブネットに分割します。

よくある質問

/24 はどういう意味ですか?
プレフィックス長です。先頭の 24 ビットがネットワーク部、残りの 8 ビットがホストの番号になります。/24 には 256 個のアドレスがあり、そのうち 254 個をホストに割り当てられます。
2 つのアドレスが使用できないのはなぜですか?
最初のアドレスはネットワークを表し、最後のアドレスはブロードキャストアドレスです。ポイントツーポイントの /31 リンク(RFC 3021)と単一ホストの /32 ルートは例外です。
プライベートな範囲はどれですか?
10.0.0.0/8、172.16.0.0/12、192.168.0.0/16(RFC 1918)です。100.64.0.0/10 はキャリアグレード NAT に使われます。これらのアドレスはパブリックなインターネットではルーティングされません。
ワイルドカードマスクとは何ですか?
ネットマスクを反転したもので、Cisco の ACL や OSPF で使われます。255.255.255.0 のワイルドカードは 0.0.0.255 です。
サブネットマスクとプレフィックス長の違いは?
どちらも同じ情報を表します。プレフィックスはマスクの先頭にある 1 のビットの数なので、/24 は 255.255.255.0、/20 は 255.255.240.0 と同じです。有効なマスクでは 1 のビットがすべて左側に連続しているため、255.0.255.0 のような値は拒否されます。
このサブネット計算機は IPv6 に対応していますか?
いいえ、IPv4 のみです。IPv6 も 128 ビットのアドレスで同じ CIDR の考え方を使いますが、数の扱いが異なります。通常の LAN は /64 で、ブロードキャストアドレスはなく、1 つの /64 に約 1,800 京個のアドレスがあるため、使用可能なホスト数を数える人はいません。
0.0.0.0/0 とは?
プレフィックスが 0 だと固定されるビットがまったくないため、すべての IPv4 アドレスを含みます。ルーティングテーブルではデフォルトルートで、より具体的な経路に一致しない場合に使われます。ファイアウォールやセキュリティグループのルールでは「どこからでも」を意味するため、本当に公開するポートにだけ開放してください。

CIDR 表記の仕組み

CIDR 表記は、192.168.10.0/26 のように、ネットワークをアドレスとプレフィックス長で表します。プレフィックスは、32 ビットの IPv4 アドレスの先頭から何ビットをネットワーク用に固定するかを示し、残りのビットでホストに番号を付けます。/26 は 26 ビットを固定して 6 ビットを残すため、2⁶ = 64 個のアドレスになります。プレフィックスが 1 変わるごとに、ネットワークのサイズは半分または 2 倍になります。

CIDR は 1993 年に従来のクラスフルな方式に取って代わったため(RFC 1519、現在は RFC 4632)、ネットワークがクラス A、B、C のブロックにぴったり合う必要はなくなりました。このサブネット計算機は参考として歴史的なクラスも表示しますが、ルーティングでは無視されます。2 進数表示ではネットワークビットとホストビットが区別して示されるため、プレフィックスがアドレスのどこで区切られ、どのビットがホストに使えるかが正確にわかります。

ネットワークアドレスとブロードキャストアドレスの計算方法

ネットワークアドレスを求めるには、IP アドレスとネットマスクのビットごとの AND を取ります。これですべてのホストビットが 0 になります。192.168.10.37/26 のネットマスクは 255.255.255.192 で、37 AND 192 は 0 なので、ネットワークは 192.168.10.0 です。ブロードキャストアドレスは逆にすべてのホストビットを 1 にしたもので、192.168.10.63 になります。使用可能なホスト範囲はその間の .1〜.62 です。

同じ計算で「この IP はあのサブネットに含まれるか?」にも答えられます。両方のアドレスをプレフィックスでマスクして比較します。192.168.10.50 をマスクすると 192.168.10.0 になるので範囲内、192.168.10.70 をマスクすると 192.168.10.64 になるので範囲外です。ここのアドレス確認はこの処理を行っています。ネットワークは CIDR プレフィックスでも、10.0.0.1 255.255.0.0 のようなドット区切りのネットマスクでも入力でき、同じ結果が得られます。

VPC 用にネットワークをサブネットに分割する方法

アドレスブロックを分割するには、より長いプレフィックスを選びます。1 ビット増えるごとにサブネットの数は 2 倍に、サイズは半分になります。/24 は 2 つの /25、4 つの /26、16 個の /28 に分割できます。「小さなサブネットに分割」パネルには、分割後のすべてのサブネットが、ホスト範囲とブロードキャストアドレス付きで最初の 256 個まで一覧表示されます。こうして作ったサブネットは、それぞれ自身のサイズの倍数の境界から始まるため、決して重なりません。

クラウドの VPC を設計するときは、/16 のように必要と思うより大きく始め、アベイラビリティーゾーンと階層ごとにサブネットを切り出しましょう。クラウドプロバイダーは追加のアドレスを予約しています。AWS と Azure は各サブネットで 2 個ではなく 5 個を確保するため、/28 で使用可能なホストは 14 個ではなく 11 個です。オフィスのネットワークや、ピアリングする可能性のある他の VPC と重なる範囲は避けてください。重なった CIDR はルーティングできません。

CIDR 早見表(IPv4)

/8 から /32 までのすべてのプレフィックスと、そのネットマスクとサイズです。/31 はポイントツーポイントリンク用に 2 つのアドレスを使用できます(RFC 3021)。

CIDRネットマスクワイルドカードマスク総アドレス数使用可能なホスト数
/8255.0.0.00.255.255.25516,777,21616,777,214
/9255.128.0.00.127.255.2558,388,6088,388,606
/10255.192.0.00.63.255.2554,194,3044,194,302
/11255.224.0.00.31.255.2552,097,1522,097,150
/12255.240.0.00.15.255.2551,048,5761,048,574
/13255.248.0.00.7.255.255524,288524,286
/14255.252.0.00.3.255.255262,144262,142
/15255.254.0.00.1.255.255131,072131,070
/16255.255.0.00.0.255.25565,53665,534
/17255.255.128.00.0.127.25532,76832,766
/18255.255.192.00.0.63.25516,38416,382
/19255.255.224.00.0.31.2558,1928,190
/20255.255.240.00.0.15.2554,0964,094
/21255.255.248.00.0.7.2552,0482,046
/22255.255.252.00.0.3.2551,0241,022
/23255.255.254.00.0.1.255512510
/24255.255.255.00.0.0.255256254
/25255.255.255.1280.0.0.127128126
/26255.255.255.1920.0.0.636462
/27255.255.255.2240.0.0.313230
/28255.255.255.2400.0.0.151614
/29255.255.255.2480.0.0.786
/30255.255.255.2520.0.0.342
/31255.255.255.2540.0.0.122
/32255.255.255.2550.0.0.011

うまく動かない、または結果がおかしいですか? このツールの問題を報告